TFS 2010 with VS2010 and VS2008 [BIDS]

May 31, 2011 at 6:47 PM
Edited May 31, 2011 at 9:10 PM

Will this work with TFS2010 using VS2010 and VS2008 (At the same time)?

I ask becuase we have installed LogSubstPol (and as far as we can tell have it installed correctly). We are using TFS2010 with VS2008 (actually we are using VS2008 Business Intelligence Development Studio [BIDS]) but when checking in we are getting an "Internal error". It all works in VS2010.

May 31, 2011 at 9:10 PM

Found the issue. You have to activate the Policy in both VS2010 and VS2008. I got confused because it was working in VS2010 but not VS2008. To make matters worse, VS2010 is my primary environment so I was used to doing everything in VS2010 - so it all "looked" right.

Once I tried to open the policy in VS2008 - Team explorer it became clearer.

Here is how I solved it:

1.       In Team explorer in VS2008, right click project|Team Project Settings|Source Control...

2.       You will get an error on loading the policy "Log Substitution Policy: Inserts Comments on Check-In", just click "OK" button.

3.       Select the tab Check-in Policy

4.       Click the Add.. button

5.       Select "Log Substitution Policy: Inserts Comments on Check-In"| then click "OK" button.

6.       Click "OK" button to close the "Source control settings" window.

7.       Close VS2008

8.       Reopen VS2008, go to the project.

9.       In Team explorer in VS2008, right click project|Team Project Settings|Source Control...

10.   Select the tab "Check-in Policy"

11.   Select the "2nd" policy type of "Log Substitution Policy: Inserts Comments on Check-In"

12.   Click the "Remove" button.

13.   Click "OK" button to close the "Source control settings" window.

14.   Close VS2008

15.   Reopen VS2008, go to the project.

It will work now.

Hope this helps....

Coordinator
Jun 1, 2011 at 5:28 PM

Thanks for sharing your experience / solution!

Jul 28, 2011 at 8:08 PM

Does not work for me.  Latest version works with TFS 2010 in Visual Studio 2010.  I get an internal error when checking in with Visual Studio 2008.  I did enable the policy as Hobo Long describes.   Any other ideas??